Approving Timesheets and leave requests

Issue/Question

How do I approve my employees’ timesheets and leave requests?

Environment

Cause

A supervisor or superuser needs to approve their employees’ timesheets and leave requests.

Resolution

All employees under South Dakota Board of Regents submit timesheets and leave requests through the SNAP portal. After an employee’s timesheet is approved by a supervisor, monthly payroll is processed electronically from the information on the employee’s timesheet. Employee leave balances are also automatically updated based on the monthly submission.

Pay periods run from the 22nd of the month through the 21st of the following month. For example:

  • The January pay period runs from Dec. 22 – Jan. 21
  • The February pay period runs from Jan. 22 – Feb. 21

Approving Leave Requests

Leave is requested through the online leave request system in Experience portal  (with the exception of Holidays and Administrative Leave which are entered directly onto the timesheet). All leave requests for the current pay period must be entered and approved before the employee submits the timesheet for approval. 

Once approved by the supervisor, leave requested in the online system is automatically populated onto the employee’s timesheet. Leave requests that are changed or approved after the timesheet has been submitted will not populate onto the timesheet.

  1. Login to the Experience portal 
  2. Click on the Employee Dashboard card
  3. Click the Approve Leave Request link under My Activities
  4. Login to the leave request site using your USD email address and password
  5. The system defaults to the Create a New Request page, Click on the Administrator link at the top of the page
  6. Select the appropriate pay period for the request (and the department and employee if necessary)
  7. Click the link to open and view the leave request
  8. Approve or deny the request. Approving will automatically update the appropriate employee timesheet and notify the employee by email that the request is approved

Approving Timesheets

The timesheet approval deadline is typically 5:00 p.m. on the 22nd of each month. If the 22nd is a weekend or a holiday, advanced announcements are sent via email to employees informing them of the deadline date for that pay period. Timesheet deadlines are also posted under the announcements channel on the Experience portal employee tab. The system cut-off for approvals is 5:00 p.m. on the deadline date. If a timesheet remains pending approval after this time, contact USD Human Resources.

  1. Login to the Experience portal 
  2. Click on the Employee Dashboard card
  3. Click Approve Time under My Activities
  4. The approval screen will default to the latest pay period that has an opened timesheet by your employees
  5. Click the date range box to select the current pay period
  6. The top section of this page houses the Distribution Status Report
  7. You may also search by employee name or ID
  8. The bottom sections of the approval screen will break down each status, except for Not Started, and list the employees under each status
    • To view employees that have not yet started their timesheets, you will need to change the selection at the top of the screen from All except not started to NOT STARTED
  9. Click an employee name
  10. On the Timesheet Detail Summary you will see Time Entry Detail by day and Summary by earn code
  11. To see details for each week and/or edit an employee’s timesheet, click Details
  12. To return a timesheet back to the employee to correct, click on Return for Correction
  13. To go back to the employee list, click Previous screen/Return 
  14. To approve the timesheet, click on Approve, This will change the status from pending to approved
  15. Follow these steps for each employee timesheet you need to approve

Note: If there are any errors on the timesheet, please refer to Correcting Submitted Timesheets article.

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Experience Portal is used to access Banner, Leave Requests, Self Service and timesheets.