Unable to Access Respondus LockDown Browser Dashboard

Issue/Question

Having issues accessing Respondus LockDown Browser Dashboard

I have had problems accessing Respondus Lockdown browser controls

Error: Unexpected Error. Please contact the system administrator. 

Environment

  • Desire2Learn(D2L)
  • Respondus LockDown Browser (LDB)
  • Respondus Monitor 

Cause

Respondus hosts data on Google Cloud Services which was experiencing issues at the time

Resolution

  1. The issue can be intermittent, please try refreshing your browser
  2. If Lockdown Browser is already installed, follow Update Lockdown Browser
  3. Install Lockdown Browser if not already installed
  4. If after a few minutes the issue persists, please contact the Service Desk 
 

Details

Article ID: 4956
Created
Thu 4/9/20 10:02 AM
Modified
Fri 2/2/24 2:12 PM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated