Body
Issue/Question
Having issues accessing Respondus LockDown Browser Dashboard
I have had problems accessing Respondus Lockdown browser controls
Error: Unexpected Error. Please contact the system administrator.
Environment
- Desire2Learn(D2L)
- Respondus LockDown Browser (LDB)
- Respondus Monitor
Cause
Respondus hosts data on Google Cloud Services which was experiencing issues at the time
Resolution
- The issue can be intermittent, please try refreshing your browser
- If Lockdown Browser is already installed, follow Update Lockdown Browser
- Install Lockdown Browser if not already installed
- If after a few minutes the issue persists, please contact the Service Desk