Issue/Question
How do I manage my Duo Devices
Environment
Cause
Need to add, rename, or remove a DUO device.
Resolution
- Open an Incognito/Private window
Note: if you don't open Incognito/Private window, you will be logged into email and not Duo
- Visit mail.usd.edu
Note: An error about the webpage security may appear, select to Proceed or Continue to site
- Enter Email Address and Password
- Click Sign on
- Click Other Options
Note: This will appear on the Duo Prompt page, if you are not prompted for Duo, you may already have an Incognito/Private window open
- Click Manage devices
- Verify with a Duo Push or a Bypass code from the USD Service Desk
You have several options available to you now
Edit the name of devices
- Click Edit on the device you want to rename
- Click Rename
- Enter the new name
- Click Rename
Remove old devices
- Click Edit on the device you want to remove
- Click Delete
- Click Delete [Device name]
Activate previous device entry on a new phone (when you have the same phone # on a new phone)
- Click I have a new phone on the phone # entry of the old phone
- Click Get Started
- Install Duo Mobile on the new device
- Click Next
- Scan the QR Code
- Click Continue
Add a new device
Note: The options available for devices to add depends on the system you are using to mange your devices. If your phone supports biometrics, you may get the option to add a biometric verification if you visit the page from your phone.
- Click Add a device
- Click the type of device you wish to add
- Follow the onscreen prompts to add that type of device