Managing Duo Devices

Issue/Question

How do I manage my Duo Devices

Environment

  • Duo

Cause

Need to add, rename, or remove a DUO device.

Resolution

  1. Open an Incognito/Private window
    Note: if you don't open Incognito/Private window, you will be logged into email and not Duo
  2. Visit mail.usd.edu
    Note: An error about the webpage security may appear, select to Proceed or Continue to site
  3. Enter Email Address and Password
  4. Click Sign on
  5. Click Other Options
    Note: This will appear on the Duo Prompt page, if you are not prompted for Duo, you may already have an Incognito/Private window open
  6. Click Manage devices
  7. Verify with a Duo Push or a Bypass code from the USD Service Desk

You have several options available to you now

Edit the name of devices

  1. Click Edit on the device you want to rename
  2. Click Rename
  3. Enter the new name
  4. Click Rename

Remove old devices

  1. Click Edit on the device you want to remove
  2. Click Delete
  3. Click Delete [Device name]

Activate previous device entry on a new phone (when you have the same phone # on a new phone)

  1. Click I have a new phone on the phone # entry of the old phone
  2. Click Get Started
  3. Install Duo Mobile on the new device
  4. Click Next
  5. Scan the QR Code
  6. Click Continue

Add a new device

Note: The options available for devices to add depends on the system you are using to mange your devices.  If your phone supports biometrics, you may get the option to add a biometric verification if you visit the page from your phone.

  1. Click Add a device
  2. Click the type of device you wish to add
  3. Follow the onscreen prompts to add that type of device
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