Removing 802.1x Eduroam Profile on macOS

Issue/Question

When I try to connect to Eduroam on my Macbook it just says "connecting" but it doesn't connect

I previously connected to Eduroam at another institution out of state or in another country and cannot connect at USD

I received an error message to contact my network administrator about my network configuration

Environment

  • MacOS
  • Eduroam

Cause

Some universities have Eduroam configured to install a profile in macOS which prevents them from successfully connecting to Eduroam at USD

Resolution

  1. Open System Settings
    1. Click in the top left of the screen
    2. Select System Preferences...
  2. Click Profiles
    Note: If you do not see Profiles, it may be under Privacy & Security
  3. Select Eduroam profile
  4. Click to remove
  5. Click Remove to confirm
  6. Repeat steps 3 through 5 until all existing Eduroam Profiles are removed
  7. Click at the top of the screen
  8. Select Network Preferences...
  9. Click Advanced... under Wi-Fi
  10. Select eduroam under the Preferred Networks or Known Networks section
  11. Click or and remove from list
  12. Click the 802.1X tab
  13. Select Wi-Fi (eduroam)
  14. Click 
  15. Click OK to close
  16. Click Apply
  17. Close System Preferences
  18. Follow steps for macOS in Connecting to Eduroam

Note: Newer operating systems may not follow the same steps (System Settings vs System Preferences UI), but the configuration file can be deleted manually by following the steps below

  1. Click Go
  2. Click Go to Folder...
  3. Type /Library/Preferences/SystemConfiguration and press Return
  4. Find and delete the com.apple.network.eapolclient.configuration.plist
  5. Restart the laptop and verify the profile no longer exists under the 802.1X tab
  6. Test connecting to eduroam
Print Article

Related Articles (2)