Enable Duo Restore on Mobile Device - iOS and ANDROID

Issue/Question

How do I enable Duo Restore on my Mobile Device

Environment

  • Apple iOS
  • Android OS
  • Duo Mobile
  • USD Account

Cause

To enable recovery of Duo Mobile Authentication on a new or factory reset device

Resolution

Android Device

  1. Open Duo Mobile App
  2. Tap overflow menu (three vertical dots) in the top right corner of the main accounts list
  3. Tap Settings
  4. Tap Duo Restore
  5. Turn on Duo Restore by tapping Backup accounts with Google Drive
  6. Select a Google account to store your backup
  7. Optionally enable third-party account restore by tapping Automatically reconnect third-party accounts
  8. Enter and confirm a recovery password that has 10-128 characters

iOS Device

  1. Back up your device to iCloud

Note: iCloud Keychain must be enabled. Nightly iCloud backups will include Duo Restore information. Encrypted iTunes backups will also work

Additional information on Duo Restore can be found Here

Details

Article ID: 6214
Created
Tue 3/30/21 4:03 PM
Modified
Wed 5/19/21 11:49 AM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated

Related Articles (3)

How to reactivate Duo on new iOS phone or Devices.
How to reactivate Duo Mobile App on New Android Phone or Android Device.
Duo Security is USD's multi-factor authentication (MFA) solution

Related Services / Offerings (1)

Two-factor authentication provides a second layer of security to any type of login, requiring extra information or a physical device to log in, in addition to your password. By requiring two different channels of authentication, we can protect user logins from remote attacks that may exploit stolen usernames and passwords.