Issue/Question
The touchscreen on my computer doesn’t seem to be working
Environment
Cause
Monitor driver needs to be reinstalled
Resolution
Note: For Lenovo systems use Lenovo System Update to detect any monitor related recommended, optional, or critical updates
- Go to HP driver download site
- Click Other
- Click in the top box and type the monitor model number
- Click Submit
- Click next to Driver-Display / Monitor
- Click Download next to the type of monitor you have
- Run the downloaded file
Note: Follow prompts to complete the driver installation
- Reboot the computer
If you need further assistance, please contact the Service Desk with the following information
- Make and model of monitor
- Location of monitor
- Asset tag (NI#) of computer monitor is connected to