Registration Self-Service Incorrect user ID or password

Issue/Question

When I click on the Registration Self Service red button in the Portal and enter my username and password, I get an error message

Error: Incorrect user ID or password.  Type the correct user ID and password, and try again. 

Environment

  • Banner Student
  • Registration Self-Service

Cause

Inactive student

Entering the wrong username or password

Resolution

  1. If you have not taken classes in the past 3 semesters, will need to contact the Admissions office 
  2. Login with your full USD Email address first.last@coyotes.usd.edu and password
    Note: If that does not work, use usdlocal\first.last
  3. Reset USD password and try logging in again
Print Article

Related Articles (1)

Troubleshooting issues accessing Self-Service Registration tool