Issue/Question
Is there a way to purge a specific email address
Email addresses not populating correctly
Can't see free/busy time when scheduling an appointment
I have sent an email to an older email that is no longer active
I unable to send email to a specific recipient
I get an error when I try to send email to certain email addresses
Error: Delivery has failed to these recipients or groups:
Environment
Cause
There is an old or incorrect email address saved in the Recent Email address list
Resolution
- Open Outlook
- Click New Email
- In the To... line, type the problem email
- Click the X next to the entry
- Open a New Email and type in the correct address