I Need to Change My Personal Email Address Associated With My USD Account

Issue/Question

My school that has been receiving all the mails so far will be shut down July 24th and I would like to request for future mails be sent towards my USD Email.

Environment

  • Personal Email
  • Rapid Identity
  • Banner

Cause

No longer have access to personal email associated with USD account

Resolution

  1. Log into Self Service
  2. Click  in the upper left corner 
  3. Click Banner
  4. Click Personal Information
  5. Click View E-Mail Addresses
  6. Below Email
    • Click  to edit
    • Click  to delete
    • Click Add New
      1. ​​​​​​​Select Email Type
      2. Enter Email address
      3. Click Add