Employee Exit Checklist for Supervisors

Issue/Question

As a supervisor, what do I need to do when my employee departs the University?

Environment

  • Faculty and Staff

Cause

An employee is departing or retiring from USD

Resolution

Note: Please see the attachment Employee Exit Checklist for Supervisors.pdf for a printable checklist

  1. Verify the employee has returned:
    • Keys (buildings, office, filing cabinets, etc)
    • Computer equipment (laptops, peripherals, laptop carrying bags, etc)
    • Office supplies
    • Unique access items (hospital badge)
  2. Advise the employee to provide Human Resources with their forwarding address for personal mail (W-2) if different from current employee records
  3. Change voice message and transfer phone
  4. Verify that faculty members have submitted grades
  5. Verify the employee has submitted their timesheet or leave report on or before the last day of work
    • If applicable, verify the employee submits appropriate reimbursement or other reports or logs (such as mileage)
  6. Notify program staff to remove employee from group emails and website directories
  7. Consider the employee’s role and access to special programs, equipment, etc. (transfer ownership of Google docs)
  8. If the employee is a researcher, please contact the Office of Research and Sponsored Programs to transfer or close research projects
  9. The employee’s final paystub will be sent to the alternate email address they provide to Human Resources

Access to USD information systems will terminate once employment ends.  Human Resources will send an email message to the offices listed below, notifying them of the employee’s departure. 

Department

Services to Terminate

Information Technology Services

Email account, SNAP, internet access, audio/visual equipment, D2L

I.D. Weeks Library

Books, library fines, videos, etc.

Business Office

Business actions (parking tickets, outstanding balances, etc.)

Accounting

Travel advances, financial manager

University Police Department and/or ITS

Building Access

Details

Article ID: 8922
Created
Wed 2/28/24 8:04 AM
Modified
Thu 2/29/24 3:41 PM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated

Related Articles (2)

Extending an employee's account
USD accounts being removed are in accordance with the Faculty/Staff account policy