Applying for a job in YourFuture

Issue/Question

How do you Apply for a Job in YourFuture as a Current Employee?

Environment

  • Employment
  • YourFuture
  • Applications

Cause

A current employee wants to apply for a job in YourFuture and needs guidance on doing so.

Resolution

  1. Login to SNAP 
  2. Click on the Employee tab from the left-hand side menu
  3. Scroll down to My Employment Details
    1. Click on Job Description on the lower right-hand corner
      Note: Ignore the Employment Opportunities as it doesn’t log the employee in properly
    2. This should log you into YourFuture
      1. If it does NOT log you in, DO NOT enter your username and password in the fields, click SSO Authentication at the bottom, then enter USD credentials
  4. Once you are logged in, click on the drop-down menu under User Group in the top right-hand corner
    1. Change User Group to Employee
  5. On the lower right-hand corner of the screen, you will see different options under My Links
    1. ​​​​​​​Applicant Portal
    2. This will log you in to the job listing site with your SNAP user account
    3. You can search and apply to jobs here
    4. Click Logout when complete (left side menu)
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Related Services / Offerings (2)

Questions or support needed regarding Benefits, Human Resources or Payroll
Experience Portal is used to access Banner, Leave Requests, Self Service and timesheets.