Body
Issue/Question
How do you Apply for a Job in YourFuture as a Current Employee?
Environment
- Employment
- YourFuture
- Applications
Cause
A current employee wants to apply for a job in YourFuture and needs guidance on doing so.
Resolution
- Login to SNAP
- Click on the Employee tab from the left-hand side menu
- Scroll down to My Employment Details
- Click on Job Description on the lower right-hand corner
Note: Ignore the Employment Opportunities as it doesn’t log the employee in properly
- This should log you into YourFuture
- If it does NOT log you in, DO NOT enter your username and password in the fields, click SSO Authentication at the bottom, then enter USD credentials
- Once you are logged in, click on the drop-down menu under User Group in the top right-hand corner
- Change User Group to Employee
- On the lower right-hand corner of the screen, you will see different options under My Links
- Applicant Portal
- This will log you in to the job listing site with your SNAP user account
- You can search and apply to jobs here
- Click Logout when complete (left side menu)