Issue/Question
I cannot view my email
I cannot access mail.usd.edu
I can access my email in Outlook but not in a browser
Error: Something went wrong. Please try again later.
Environment
Cause
Known issue. Microsoft is currently working on implementing a fix. Issues currently being resolved on case-by-case basis
Resolution
Note: For Error: Microsoft.Exchange.Clients.Owa2.Server.Core.OwaUserHasNoMailboxAndNoLicenseAssignedException follow Unable to Access Email
- Please contact the Service Desk with the following information:
- Name
- USD email address