Issue/Question
Laptop indicates that something has been unplugged and the monitors go black
Monitors will go off and on
The screen jumps up and down when connected to an external monitor
My monitor flicks on and off a few times, then once on flickers for several minutes before starting to work properly
My computer is only displaying one of my two monitors
Lines on monitor
There is a blue box on my computer screen
Environment
- Docking station
- External monitors
- Belkin dock
- Lenovo dock
- Surface dock
Cause
Defective or Loose cable connection
Old firmware or drivers
Incompatibility
Resolution
Note: If using USB-C docking station, make sure cable is securely connected to dock and laptop
- Ensure computer operating system and driver updates are installed
- Power monitor off
- Unplug power cord from monitor
- Wait 10 seconds
- Plug power cord back into monitor
- Remove laptop from dock
- Attach laptop to dock
- Turn on monitor
- Check all power and video cable connections
- Disconnect all cables and devices from monitor except power and video cables
- Reboot computer
- Remove video cable from docking station
- Disconnect and reconnect video cable to video adapter
- Reconnect video cables
- Replace video cables
- Use the On Screen Display (OSD) buttons on the monitor to change the source setting to match the video cable type