Issue/Question
My computer updated and now it is saying that there is no scanner detected
Environment
Cause
After the 24H2 Windows 11 update, eSCL capable USB scanners and printers are not detected correctly by Windows, and may not work
Resolution
HP Scanners
- Download the HP scan and driver pack for your scanner model from HP's website
Note: If the scanner drivers and HP Scan software are already installed, skip to step 9
- Open the installer
- Click Continue
- Select USB - Connect the device to this computer using a USB cable.
- Click Next
- Check Continue the installation without connecting now, I will connect the device later.
- Click Skip
- Click Finish
- Type Device Manager into the Search bar at the bottom of the screen
- Click Device Manager
- Expand Universal Serial Bus Controllers
- Follow these steps for each USB Printer support device until prompted to reboot
- Right-Click USB Printer support
- Select Properties
- Select the Driver tab
- Click Update Driver
- Select Browse for drivers on your computer
- Click Let me pick from a list of available drivers on my computer
- Select Universal Serial Bus Controllers (if prompted to select a device)
- Click Have Disk...
- Click Browse...
- Browse to C:\Program Files\HP\HP Scan\DriverStore\HPScanUnusedStubDriver
- Select UnusedScanStub.inf
- Click Open
- Click OK
- Select the correct scanner from the list
Note: If the scanner model is not listed, try one of the .inf files under C:\Program Files\HP\HP Scan\DriverStore\NGScanDriver\ instead
- Click Next
- Click Close
- Click Close
- Try using the scanner again
Note: This is a temporary fix. If the scanner is powered down or goes into standby mode, a restart while the scanner is powered on and active may be necessary to make it functional again
Fujitsu Scanners
- Type Device Manager into the Search bar at the bottom of the screen
- Click Device Manager
- Expand Imaging devices
- Right-Click the scanner
- Click Update Driver
- Select Browse for drivers on your computer
- Click Let me pick from a list of available drivers on my computer
- Select the second driver listed
- Click Next
- Click Close
- Restart the computer and try using the scanner again