USB Scanner Not Working After Windows Updates

Issue/Question

My computer updated and now it is saying that there is no scanner detected

Environment

  • Windows 11

Cause

After the 24H2 Windows 11 update, eSCL capable USB scanners and printers are not detected correctly by Windows, and may not work

Resolution

HP Scanners

  1. Download the HP scan and driver pack for your scanner model from HP's website
    Note: If the scanner drivers and HP Scan software are already installed, skip to step 9
  2. Open the installer
  3. Click Continue
  4. Select USB - Connect the device to this computer using a USB cable.
  5. Click Next
  6. Check Continue the installation without connecting now, I will connect the device later.
  7. Click Skip
  8. Click Finish
  9. Type Device Manager into the Search bar at the bottom of the screen
  10. Click Device Manager
  11. Expand Universal Serial Bus Controllers
  12. Follow these steps for each USB Printer support device until prompted to reboot
    1. Right-Click USB Printer support
    2. Select Properties
    3. Select the Driver tab
    4. Click Update Driver
    5. Select Browse for drivers on your computer
    6. Click Let me pick from a list of available drivers on my computer
    7. Select Universal Serial Bus Controllers (if prompted to select a device)
    8. Click Have Disk...
    9. Click Browse...
    10. Browse to C:\Program Files\HP\HP Scan\DriverStore\HPScanUnusedStubDriver
    11. Select UnusedScanStub.inf
    12. Click Open
    13. Click OK
    14. Select the correct scanner from the list
      Note: If the scanner model is not listed, try one of the .inf files under C:\Program Files\HP\HP Scan\DriverStore\NGScanDriver\ instead
    15. Click Next
    16. Click Close
    17. Click Close
  13. Try using the scanner again
    Note: This is a temporary fix. If the scanner is powered down or goes into standby mode, a restart while the scanner is powered on and active may be necessary to make it functional again

Fujitsu Scanners

  1. Type Device Manager into the Search bar at the bottom of the screen
  2. Click Device Manager
  3. Expand Imaging devices
  4. Right-Click the scanner
  5. Click Update Driver
  6. Select Browse for drivers on your computer
  7. Click Let me pick from a list of available drivers on my computer
  8. Select the second driver listed
  9. Click Next
  10. Click Close
  11. Restart the computer and try using the scanner again
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