Logging into Adobe Creative Cloud Shared Device License

Issue/Question

Steps for logging into Adobe Creative Cloud on a computer that uses a shared device license

Environment

  • Computer Lab
  • Classroom

Cause

Adobe shared device license installed

Resolution

  1. Open Adobe Application
  2. Type USD credentials (full email address)
    Note: If the user already has an Adobe ID with that address there will be an option to select Personal Account or Company or School Account
  3. Select Company or School Account to be directed to the USD SSO page
  4. At the USD SSO page type in credentials
  5. The Adobe application will launch
  6. Users must sign out when they are finished
    1. Click Adobe Profile Icon in upper right and choose Sign Out or Help - Sign out
      Note: If the user does not sign out of Adobe, the system will stay signed in to that account, even if someone different logs into the computer

Details

Article ID: 4496
Created
Fri 1/10/20 1:08 PM
Modified
Fri 1/26/24 10:14 AM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Not Validated

Related Articles (1)

Checking to see if a particular computer has a device license for Adobe Creative Cloud rather than a named license installed.