Logging into Experience portal & Self Service

Issue/Question

How do I  log into SNAP
How do I log into Self Service
Single Sign-on is not working
reset password

Error:  username not found...Logout successful 
Error: You are not authorized to view this page

Environment

Cause

Password is not known
Account not created

Resolution

  1. Navigate to Experience portal 
  2. Log in with your USD email address and password
    Note: Log in with  usdlocal\username if email address doesn't work
  3. If using Internet Explorer, verify you are using the correct version
  4. Clear Cache and Cookies 
    Note: If your USD account is no longer active or available to you, you cannot log in

Please contact the Service Desk if you need further assistance

 

Access Experience Print Article

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Related Services / Offerings (2)

Experience Portal is used to access Banner, Leave Requests, Self Service and timesheets.
Ask ITS a general question related to technology services provided at USD. Request new software or hardware installation.