Unable to Log Into MBM

Issue/Question

I have been trying to log into MBM but cannot access it. 

Forgot username and password

Error: We were unable to retrieve your full information. Please logout of the portal and back in to try again. 

Environment

  • MBM

Cause

2 Possible Causes, Access isn't setup or using wrong log in credentials

Resolution

  1. Double-check log in credentials
    1. Use your USD Username and Password
      Note: Do not use your email address as your username
    2. Reset Password

Please contact the Service Desk if you need further assistance