Cognos Report Does Not Run

Issue/Question

Unable to run Reports

A cognos report is not working. 

Error: You do not have access to this report content or the content has moved.

Error: Unable to find the connection ODS in the content store

Error: Data source adapter error: java.sql.SQLException: ORA-01427: single-row subquery returns more than one row

Run report behind the scene to excel and I never received email with the report

Environment

  • Cognos

Cause

User has not been assigned to the appropriate permissions group in Cognos

OR

You are running the report from a stale link in your Recents links

Resolution

  1. If you are running the report from a link in Recents, hover over the blue link to the report to find out the path to the report (for example, the "SAS115 GL Level 6 report")
    1. If the path contains 'Obsolete' or 'Archive', then you are running an old version of the report
    2. To correct this, follow the path to the folder BEFORE the Archive or Obsolete folder 
    3. For instance, if the path to the report is: Team content > Banner > USD > Common Departmental Reports > SAS 115 > Obsolete, navigate to the Team content >Banner > USD > Common Departmental Reports > SAS 115 folder
    4. Execute the "SAS115 GL Level 6 report" report from that folder
    5. Your Recents will now contain a link to the "SAS115 GL Level 6 report" in the correct location
    6. If you need further assistance, follow the instructions in 2, below
  1. Please contact the service desk with the following information:
    1. Name of Cognos Report
    2. Location of Cognos Report
    3. Error Message received
    4. User ID
    5. Phone number

ITS STAFF ONLY

  1. Follow the instructions to Granting Cognos Reporting Access

If the issue is with running the report behind the scene and the user never receiving an email with the report:

  1. Follow the instructions for Researching Possible Error in Cognos