Cognos Report Does Not Run

Issue/Question

Unable to run Reports

A cognos report is not working. 

Error: Unable to find the connection ODS in the content store

Error: Unable to find the connection "colleaguePROD" in the content store

Error: Run-tem error '3151':

ODBC--connection to 'CODSP' failed.

Error: Data source adapter error: java.sql.SQLException: ORA-01427: single-row subquery returns more than one row

Run report behind the scene to excel and I never received email with the report

Environment

  • Cognos

Cause

 user has not been assigned to the appropriate permissions group in Cognos

Resolution

  1. Please contact the service desk with the following information:
    1. Name of Cognos Report
    2. Location of Cognos Report
    3. Error Message received
    4. User ID
    5. Phone number

ITS STAFF ONLY

  1. Follow the instructions to Granting Cognos Reporting Access

If the issue is with running the report behind the scene and the user never receiving an email with the report:

  1. Follow the instructions for Researching Possible Error in Cognos

 

 

Details

Article ID: 1425
Created
Wed 11/28/18 7:42 AM
Modified
Wed 3/4/20 3:59 PM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated