Classify and Protect Documents in bulk

Issue/Question

How do I restrict or encrypt a document to protect it

How do I restrict or encrypt a large group of documents in bulk

Environment

  • Office
  • Word, Excel, Powerpoint
  • PDF
  • Restricted
  • Data Classification
  • Internal Users
  • External Users

Cause

Sensitive or Restricted data can be protected by applying Microsoft Sensitivity Labels to documents.  Data Stewards at USD may opt to secure privileged data in this way.  Current versions of Office, Azure Information Protection Viewer, Adobe Acrobat and Adobe Acrobat Reader support the ability to label and read these types of secured files.  Older versions of some software may not support this feature and you will need to upgrade or update the program to view the data.  

Resolution

  1. Make sure you have installed the latest version of Azure Information Protection Viewer
  2. Open File Explorer and Select a group of files to protect
  3. Right-click and select Classify and Protect
  4. Sign-in with your USD account, if prompted
  5. Set the label on the file to restricted, this encrypts the file and
    • Makes files read-only
    • Disables printing
    • Disables screenshots
    • Disables editing
    • Disables save-as
    • Disables export-as 
  6. Select the customer permission level of Viewer
  7. Give users permission to the view the file
    • Click the address book icon to select users or groups from the USD address book
    • Add lists of users internal and external using the format below
      • john@contoso.com ; sales@contoso.com ; fabrikam.com ; etc
    • Add the group of a Microsoft Teams site to make a dynamic user list that changes as you change membership of your Microsoft Teams site
  8. Set an expiration date for access to the files
  9. Select Apply to finalize
  10. Upload the newly protected documents to your Team Site or share them as authorized by Data Stewards.
  11. NOTE: Once files have been classified and protected, permission changes require that steps 3-10 be repeated.  This includes uploading the documents again.

Please contact the Service Desk if you need further assistance

Details

Article ID: 7361
Created
Tue 9/6/22 11:24 AM
Modified
Mon 10/24/22 10:54 AM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
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Validated