Issue/Question
How do I view all of my completed DocuSign documents?
Some of my completed DocuSigns have disappeared.
The Completed count on the DocuSign homepage has decreased
Environment
Cause
A filter has been applied to only show DocuSign activity for recent months
Resolution
- Sign into DocuSign
- Click Manage tab
- Click Completed
- Click FILTERS
- Select All from the Date drop-down menu
- Click APPLY