Changing Direct Deposit

Issue/Question

How do I update my bank account for my payroll direct deposit?

When updating my bank account in the Pay Information - Direct Deposit Allocation, the system didn't update my payroll direct deposit account.

Environment

  • SNAP
  • Self Service
  • Direct Deposit
  • Paucheck

Cause

The University is very careful about protecting employee identity and pay. Changes to direct deposit require employees to personally contact USD HR/Payroll. Requesting a change in direct deposit without a personal contact with HR/Payroll  is not allowed because of the unlikely event an employee’s email account is compromised.

Resolution

  1. If possible, visit HR/Payroll at Slagle Hall Room 206 to request changes to your direct deposit. Please bring the following:
    1. Photo ID to verify identity
    2. Bank information
      1. Routing number and account number
        • a voided check (if possible)
        • letter from the bank with routing and account information to ensure the bank information is correct
  2. If you are not able to visit in person, contact HR/Paroll
  1. After HR/Payroll staff has confirmed the employee’s identity and validity of the request, the employee can fill out a new direct deposit form in person or Payroll can send an electronic direct deposit form through DocuSign which will be sent to the employee’s email.

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Questions or support needed regarding Benefits, Human Resources or Payroll