Requesting Vendor Account Password Reset

Issue/Question

Our support vendor has a vendor account that was just reactivated but are unable to logon 

Environment

  • USD Vendor Account

Cause

Password is not working or was forgotten 

Resolution

  1.  Please contact the Service Desk with the following information: 
    1. Vendor Account Username

ITS STAFF ONLY

  1. Follow Resetting Vendor Account Passwords