Known Issues or Limitations of Respondus Lockdown Browser for Chromebook

Issue/Question

What are the known issues or limitations of using Respondus Lockdown Browser on a Chromebook? 

Environment

  • Desire2Learn (D2L) 
  • Respondus Lockdown Browser
  • Chromebook (Chrome OS)

Cause

This is a Beta release and does not have full functionality compared to Windows or Apple installations 

Resolution

  1. Limitations and/or known issues with LockDown Browser for Chromebook: 
    • Quiz passwords (specified via the "optional password" field in the LockDown Browser Dashboard) aren’t currently supported
    • The Early Exit feature in LockDown Browser isn’t currently supported
    • LockDown Browser’s Calculator and Spreadsheet features aren’t currently supported
    • The extended keyboard function (for adding symbols and special characters) isn’t currently available
    • (Canvas) When using New Quizzes, students currently encounter a warning that the browser can’t open this page (this can be ignored)
    • LockDown Browser’s Help Center is currently unavailable
    • Allow access to specific external web domains option is currently not supported
    • (Brightspace) Pop-ups need to be enabled in Chrome for the server otherwise the student gets stuck on the Start Quiz page
    • Software is allowing students to take a quiz with Respondus Lockdown Monitor without recording the tester 

Note:  Linux and Chrome OS are not supported!
While core functions of our online courses will work on most mobile devices & smartphones, other functions will not.  If using mobile devices—smartphones (e.g., an iPhone™), tablets (e.g., an iPad™), Chromebooks, You MUST have access to another computer. This is outlined in Technology Requirements section of the USD Online & Off-Campus Education ​​​​Online student Handbook

Print Article

Related Articles (2)

During the beta period, instructors will need to enable the use of the Chromebook version on a per exam basis.
Installing LockDown Browser to your Chromebook