Issue/Question
How do I use TurningPoint to respond to questions in class?
Environment
- TurningPoint 8
- PointSolutions
Cause
Instructor is using TurningPoint in class.
Resolution
Registering Your Clicker for Class
- Clickers are registered through a Turning account, which is accessed through a link in your D2L course
- Instructions for creating a Turning account and linking it to your D2L account are available here
- TurningPoint clickers and subscriptions can be purchased directly from the TurningPoint/PointSolutions Store
Note: Discounts are available if purchasing subscriptions for longer than a year. If you know a course you will take in a later year uses TurningPoint it might be worthwhile to buy a longer subscription See the TurningPoint/PointSolutoins Store for pricing
Changing the Channel on Your TurningPoint Clicker
Note: Clicker channels vary from classroom to classroom, please ask your instructor what the correct channel is for your class.
- On the clicker press the Channel, CH or GO button
- Enter the two-digit channel number provided by your instructor
- Press the Channel, CH or GO button again
Note: A green flash indicates the channel was successfully changed. A red flash indicates that the response was not received. Multiple yellow flashes indicate the response is sending