Signing in to Adobe Creative Cloud

Issue/Question

I received email from Adobe saying "Access is granted. Enjoy All Apps plan now." I already had Creative Cloud, what do I do now?

Photoshop message states "license has expired"

Environment

  • Adobe Creative Cloud
  • Enterprise license

Cause

Some Adobe accounts were switched from Personal accounts to School accounts

Resolution

  1. Go to Adobe
  2. If already signed in
    1. Click blue circle icon in upper right corner
    2. Select Sign Out
  3. Click Sign In
  4. Enter USD email address
  5. Click Continue
  6. Select Company or School Account

Please contact the Service Desk if you would like additional assistance.

Details

Article ID: 5580
Created
Tue 9/29/20 12:33 PM
Modified
Fri 1/26/24 10:28 AM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated

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