Unable to Establish Secure Connection When Trying to Access website - Mac OS

Issue/Question

Unable to access usd.edu or other secure websites

Environment

  • Mac OS X 10.6 or later
  • Safari
  • Firefox
  • Google Chrome
  • How to open formerly secure site
  • Cannot access vendor secure site

Cause

Most browsers do not support the older Mac OS X version and our out of date

Site provided by vendor maybe down

Resolution

  1. Verify what version of the Mac OS is on the computer
    Note: may need to update the Mac OS to a newer version that supports the latest internet browsers
  2. Verify version of the browser and check for updates
  3. Try a different web browser
  4. Contact Vendor and verify if the site provided is working or down