USB Devices Not Working When Connected to Docking Station

Summary

Power-cycling the dock to re-gain USB connectivity

Body

Issue/Question

My USB devices will not work when the laptop is connected to the dock

My USB printer stopped working

Environment

  • Thinkpad OneLink+ Dock
  • USB devices
  • HP laptops

Cause

Docking station needs to be power cycled

Multiple causes

Resolution

Note:  Make sure power strip is powered on

  1. Re-seat USB cables on dock
  2. Unplug power cord from dock
  3. Plug power cord into dock
  4. Verify connectivity
  5. Restart Computer if necessary
  6. Update drivers and firmware for computer and dock

Details

Details

Article ID: 2095
Created
Thu 1/24/19 8:47 AM
Modified
Fri 6/23/23 3:49 PM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated

Related Articles

Related Articles (1)

Changing USB selective suspend setting to Disabled