Receiving Multiple Phishing Training Reminders

Summary

What to do if you believe you are receiving phishing training enrollment messages in error

Body

Issue/Question

Please stop sending multiple phishing training reminders

I just completed training, do I need to complete this training again?

Environment

  • KnowBe4 Training
  • Email

Cause

The University conducts phishing simulations every month, and some users will receive training reminders if they click a link or open an attachment.

Resolution

  • Phishing simulations run every month
  • Customers who do not complete the training will receive a reminder after 5 business days
    Note: Training is the same for all customers no matter how many phishing simulations they fail
  • Annual security awareness training is separate from monthly phishing training and is mandatory for all staff
  • If you believe you are receiving a message in error, please contact the Service Desk with the following information: 
    • The dates you received the messages
    • The dates you completed training

ITS STAFF ONLY

  1. Follow Investigating Phishing Training Reminders

Details

Details

Article ID: 5643
Created
Tue 10/13/20 6:20 PM
Modified
Wed 11/17/21 3:25 PM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated