Unsupported Web Browsers Policy - Internal ITS Article

Body

Issue/Question

How do I respond to a customer inquiry about unsupported web browsers

Environment

  • Windows
  • Mac
  • DLP
  • Data Protection

Cause

Only supported web browsers are now allowed on university owned devices.

Resolution

USD STAFF ONLY

  1. Form letter response for use with customer communication
    1. As part of our ongoing efforts to protect university data and uphold security and compliance standards, the USD Information Security Office is implementing a policy to restrict the use of unsupported web browsers on university-managed systems and networks.  

      Unsupported browsers can include built-in technologies that may bypass university security protections, land lack compatibility with essential enterprise tools such as DLP, policy enforcement, and centralized updates. Blocking these browsers aligns with USD’s Information Security and Data Responsibilities Policy to ensure visibility, control, and compliance with data protection requirements.

  2. If the customer requests an exception please gather the use case and business justification for the exception and create a task for Security Team

Details

Details

Article ID: 9805
Created
Mon 7/14/25 1:28 PM
Modified
Mon 7/14/25 2:04 PM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated

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