Body
Issue/Question
How do I respond to a customer inquiry about unsupported web browsers
Environment
- Windows
- Mac
- DLP
- Data Protection
Cause
Only supported web browsers are now allowed on university owned devices.
Resolution
USD STAFF ONLY
- Form letter response for use with customer communication
- As part of our ongoing efforts to protect university data and uphold security and compliance standards, the USD Information Security Office is implementing a policy to restrict the use of unsupported web browsers on university-managed systems and networks.
Unsupported browsers can include built-in technologies that may bypass university security protections, land lack compatibility with essential enterprise tools such as DLP, policy enforcement, and centralized updates. Blocking these browsers aligns with USD’s Information Security and Data Responsibilities Policy to ensure visibility, control, and compliance with data protection requirements.
- If the customer requests an exception please gather the use case and business justification for the exception and create a task for Security Team