DYMO Label Printer Is Not Printing

Summary

Steps taken to resolve DYMO LabelWriter 550 Turbo not printing issue

Body

Issue/Question

My label maker will not print labels

Environment

  • Windows 11
  • DYMO LabelWriter 550 Turbo
  • DYMO Connect

Cause

There are many things that can cause this issue

Resolution

  1. Press 
  2. Select Settings
  3. Click Bluetooth & devices
  4. Select Printers & scanners
  5. Select DYMO LabelWriter 550 Turbo
  6. Click Remove
  7. Reboot
  8. Login
  9. Unplug DYMO USB cable from computer
  10. Wait about 1 minute
  11. Plug DYMO USB cable back in
  12. Open DYMO Connect
  13. Print label

Details

Details

Article ID: 9319
Created
Tue 10/1/24 4:58 PM
Modified
Tue 10/8/24 12:08 PM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated