Unable to Open Link in D2L, Blank White Page Loads

Summary

How to enable Cross-Site tracking to prevent issues clicking on links in D2L.

Body

Issue/Question

There are students unable to access D2L link on Mac

A blank white screen appears when clicking a link on a D2L course

Environment

  • MacOS
  • Windows
  • iOS
  • Firefox
  • Safari
  • Chrome

Cause

Cross-Site Tracking is disabled by default in Firefox, Safari, and iOS

Resolution

Enabling Cross-Site Tracking:

 

Safari

  1. Open Safari
  2. Click Safari at the top left of the screen
  3. Select Settings
    Note: Select Preferences if Settings is not an option
  4. Click Privacy
  5. Uncheck  Prevent Cross-site tracking
  6. Restart Safari

Firefox

  1. Open Firefox
  2. Click  in the top right corner
  3. Click Settings
  4. Click Privacy in the top panel
  5. Select Custom
  6. Uncheck Cookies
  7. Click  Reload All Tabs

iOS

  1. Open  Settings
  2. Click Safari
  3. Click Privacy & Security
  4. Toggle  Prevent Cross-Site Tracking to Off​

Chrome (Enabled by Default)

  1. Open Chrome
  2. Click  in the top right corner
  3. Click Settings
  4. Click Privacy and security
  5. Click Third-party cookies
  6. Toggle  Send a "Do Not Track" request with your browsing traffic to Off

Details

Details

Article ID: 8670
Created
Thu 9/14/23 4:02 PM
Modified
Mon 9/16/24 1:26 PM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated