Scheduled Report/Job in Cognos Did Not Run

Summary

Cognos scheduled reports/jobs depend on background credentials in Cognos
Changing ADFS password requires you to MANUALLY renew your credentials in Cognos to run background tasks

Body

Issue/Question

Expected Cognos scheduled report did not show up as expected

Report output expected on RIS FTP server is not found or does not have the correct updated date

Report output expected in a local share is not there or has the wrong date

  • Environment

  • Cognos
  • ADFS

Cause

One possible cause for this is that the person who scheduled the report/job needs to renew their ADFS credentials in Cognos after they have changed their USD password

Note: As of April 2021, all schedules on INTERFACE/APPLICATION FEED reports/jobs are running under the USD Congos Service ID, so this should only be an issue if THAT password is changed

(Credential renewal is a MANUAL process, no known automation possible, YET)

Note: YOU MUST PERFORM A CREDENTIAL RENEWAL IN COGNOS EVERY TIME YOU CHANGE YOUR USD PASSWORD

If the file on the local share has the wrong date, but the copy on the FTP directory is correct, it is possible that the scheduled job in Cognos fired after the Secure FTP process ran (scheduled incorrectly or was delayed for some reason)

If the files were not updated on the FTP server, it is possible that there was a problem with the Storage Area Network (SAN) - only RIS could tell if that were the case

Resolution

If issue is due to needing to renew ADFS credentials

  1. Log in to Cognos as you normally do
  2. In the upper right part of the window is a Person icon  - click this
  3. Click the My Preferences link
  4. Click the Personal tab
  5. Click the Advanced link
  6. Click the Renew option to the right of the Credentials line
  7. Enter your domain ID in the User ID: field -- usdlocal\yourdomainID
  8. Enter your domain password in the Password field and again in the verify password field
  9. Click OK
  10. The scheduled job will not fail because of credentials the next time
  11. If YOU did not schedule the report/job, contact Service Desk with the name of the report that was expected

If issue is because timing of report is off from when FTP process runs

  1. Log in to Cognos as you normally do
  2. Click the report entry context menu 
  3. Click Properties
  4. Click the Schedule tab
  5. Click Edit
  6. Specify the schedule options
    1. Under Period
    2. Click Time field and change to what is needed
    3. Click Save

Please contact the Service Desk if you need further assistance

ITS STAFF ONLY

  1. If the files are missing contact RIS to see if here were any storage issues/Cognos issues at the time in question

Details

Details

Article ID: 5915
Created
Wed 12/23/20 4:10 PM
Modified
Thu 4/22/21 6:46 PM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated