Problems Logging into Webmail and my.usd.edu

Summary

Wait 20 minutes and try again when experiencing issues logging into your USD account

Body

Issue/Question

I can't log into webmail and my.usd.edu

Environment

  • USD Account
  • ADFS
  • Desire2Learn (D2L)
  • MyU Portal (my.usd.edu)
  • Webmail (mail.usd.edu)

Cause

Your account may be locked due to too many attempts to log in with an incorrect password.

Resolution

  1. Wait 20 minutes without attempting to sign in
    Note: If your account is set up on any devices, like a phone, please turn that device off for the 20 minutes
  2. Attempt to sign in again
  3. Please contact the Service Desk with the following information if you are still unable to sign in: 
    1. Name
    2. Phone number
    3. Site you are trying to log into

ITS STAFF ONLY

  1. Follow Unlocking an ADFS Account

Details

Details

Article ID: 5072
Created
Fri 5/8/20 3:26 PM
Modified
Thu 10/31/24 4:24 PM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated