Body
Issue/Question
I can't log into webmail and my.usd.edu
Environment
- USD Account
- ADFS
- Desire2Learn (D2L)
- MyU Portal (my.usd.edu)
- Webmail (mail.usd.edu)
Cause
Your account may be locked due to too many attempts to log in with an incorrect password.
Resolution
- Wait 20 minutes without attempting to sign in
Note: If your account is set up on any devices, like a phone, please turn that device off for the 20 minutes
- Attempt to sign in again
- Please contact the Service Desk with the following information if you are still unable to sign in:
- Name
- Phone number
- Site you are trying to log into