Being a KCS Contributor

Summary

This article lists the competencies, responsibilities and range of knowledge for a KCS Contributor (the second stage of licensing for KCS)

Body

Issue/Question

What are the Knowledge Centered Service (KCS) Contributer responsibilities

Environment

  • TeamDynamix
  • ITS

Cause

The KCS Licensing Model consists of various stages: 1. KCS Candidate, 2. KCS Contributer, 3. KCS Publisher and KCS Coach or Knowledge Domain Expert

Resolution

KCS Contributor  

 The KCS Contributor reviews (as they reuse) or finishes KCS articles that are framed by themselves or others, making sure the articles adhere to the content standard. The KCS Contributor has the capability and authority to create or validate articles in their product area without review by a Coach. They may also author and approve articles for broad audience visibility.  They may directly improve articles that have article visibility set to Internal and should flag articles in an External state that need to be updated or improved.  

 

The KCS Contributor competencies are incremental to those of KCS Candidate and involve a detailed understanding of the importance of the context of the audience, the content standard, the KCS Article Quality Index, and the KCS processes. They should be able to work independently by creating well-structured KCS articles and be adept at enhancing others' articles to make them visible to a wider audience.  The KCS Contributor should also be able to demonstrate understanding by passing an exam.   

 

Competencies 

All of the KCS Candidate competencies plus the following: 

  • Consistently create articles that do not require rework (based on performance in the environment) 
  • Collective ownership “if you find it / use it, you own it”.  It is critical that users of the knowledge take responsibility for what they see and use in the knowledge base – If an article is unclear, “fix it or flag it” 
  • Article review processes in the workflow and random sampling 
  • Concepts of findability and usability 
  • Customer requirements are speed and accuracy 
  • Balance diversity and consistency – issues should be described in as many ways as customers will experience them, while maintaining a consistent form of documentation 
  • The concept of good enough 
  • Article should evolve through use and be specific to the experience of a customer’s issue – article extension should be based on demand 
  • One knowledge article per issue; however, this is not an absolute and the criteria should be developed based on experience in the environment.  An exception that needs to be considered is context – two articles may exist for the same issue but are targeted at different audiences (novice versus expert) 
  • Articles that are reused are candidates for a larger audience and should be moved closer to the customer 
  • Visibility should be appropriate to the audience – not everyone sees everything 
  • Context is from the perspective of the audience 
  • Articles are created in the context of a specific audience 
  • Balance between completeness and usability 
  • Use numbered steps to describe a resolution process 
  • Use the vocabulary and technical perspective/ capability of the target audience (context) 
  • Capture the customer context during the conversation 
  • Capturing the issue and environment information in the process enables the “search early, search often” practice, which reduces the risk of spending time solving an issue that has already been solved 
  • A certain level of redundancy and diversity in a knowledge practice is healthy.  Redundancy becomes an issue only when it adversely affects the findability and usability of the content. 
  • Examples of acceptable redundancy are: 
  • Articles for the same situation but for different target audiences 
  • Articles that capture in whole different experiences but have the same resolution 
  • The content standard should describe the criteria for unwanted redundancy, and as redundant articles are found they should be merged into one. 

Responsibilities 

All of the KCS Candidate responsibilities plus the following: 

  • Fixing any article that they are comfortable fixing 
  • Flag articles they do not have expertise to fix 
  • Ensure articles adhere to content standard 
  • Approve articles that have been validated (3 reuses) 
  • Create and validate articles without being reviewed by coach 
  • Flag published articles

 KCS Roles Matrix

Please click on the link to see the article detailing the rights a Contributor has.

Details

Details

Article ID: 282
Created
Fri 7/20/18 3:54 PM
Modified
Tue 6/6/23 1:09 PM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated