XPanel and Touch Panel do not Respond

Summary

What to do if in a classroom or conference room and the Touch Panel or XPanel will not respond

Body

Issue/Question

The Crestron XPanel and Touch Panel say touch the screen to begin but nothing happens upon touching the screen

The XPanel says it cannot connect

The Touch Panel is blank and does not come on

Touch Panel loads to a blank white screen

The Touch Panel will not turn on

The Touch Panel hangs

Error message CNX Connection Disconnected Please wait one moment while the panel syncs with the system...

System Offline

Error: Hm... can't reach this page

Environment

  • Smart Classroom
  • Conference Room
  • Crestron XPanel or Touch Panel
  • QSC Touch Panel or XPanel

Cause

The Touch Panel and XPanel cannot communicate over the network with the room controller or switch

Resolution

Contacting the Service Desk

  1. Please contact the Service Desk with the following information:
    1. Building Name
    2. Room Number
    3. Instructor Name
    4. Urgency
    5. Classroom availability 
    6. Detailed information of the issue

As a temporary work around follow these steps:

  1. Locate the XPanel shortcut on the PC's Users Desktop
  2. Double-click the icon to open the XPanel application
  3. Try using the application like you would the touch panel to start your class
  4. Please be sure to report the touch panel issue to the service desk using the steps from Contacting the Service Desk

Details

Details

Article ID: 1843
Created
Tue 1/8/19 10:30 AM
Modified
Thu 11/14/24 4:57 PM
KCS Article Status
WIP: Only Problem & some Environment captured
Not Validated: Complete & Resolution captured, confidence lacks in structure, content, no feedback
Validated: Complete & reusable, used by licensed KCS user, confidence in resolution & std. compliance
Validated