Upgrading or Replacing Hardware in a University Owned Computer
Summary
Requesting installation, upgrade, or replacement of computer hardware
Body
Issue/Question
- I would like my Solid State Drive (SSD) upgrade drive to be installed
- I need a charging cable for my laptop
- My desktop system is “clicking” now and then
- I would like more memory (RAM) added to my computer
- I need a PCIe card installed in my computer
- My battery is not holding a charge
Environment
- University Owned Desktops
- University Owned Laptops
Cause
- Requesting an upgrade
- Requesting back up or replacement of back up harddrive
- Computer running slow
- Failing battery
Resolution
- Please contact the Service Desk with the following information:
- What you would like upgraded or replaced
- The building and room number where the machine is located
- Times you are available
ITS STAFF ONLY
- Assign to Service Desk or to the technicians assigned to the building
Details
Details
Article ID:
1124
Created
Thu 11/1/18 4:54 PM
Modified
Thu 6/15/23 9:06 AM